Gecko® Circuit Board for HydroQuip Controls - 33-0024B-K

HQ0042
Gecko® Circuit Board for HydroQuip Controls - 33-0024B-K

Gecko® Circuit Board for HydroQuip Controls - 33-0024B-K

HQ0042
Regular price $349.95
/
Qualifies for Free Shipping Free standard shipping to US contiguous 48 states for $100+ merchandise total.
Standard Delivery to US-48 Only This item is not available for air shipment, nor for delivery to Alaska, Hawaii, or Canada.
  • In stock, ready to ship
  • Inventory on the way

This printed circuit board (PCB) is for HydroQuip hot tub control systems. Supports 2 pumps, blower, circulation pump, ozone/UV-C, and light.

  • Genuine OEM Gecko® Board
  • Compatible with ECO-3 digital topside control keypads

Product Notes: Replacement circuit board for HydroQuip CS4230, CS6230 & CS9230. Circuit boards must be identified with the chip number and/or part number to guarantee the existing control keypad and other components will function. See below for associated part and chip numbers. Circuit boards are not returnable, but are covered under warranty.

How to Find Your Circuit Board Chip Number

Details:

Primary Pump Circuit: 2-Speed - 120V/240V

Secondary Pump Circuit: 1-Speed - 120V/240V

Blower Circuit: 120V/240V

Light Circuit:12V Spa Light

Ozone/UVC Circuit: 120V/240V

Circulation Pump Circuit:120V/240V

A/V Circuit:Not Supported

Compatible Control Keypad Type: ECO-3 Digital

Compatible Keypad Part Numbers:34-0197

Chip/Part Numbers: 33-0024B-K, 33-0024-R1, 33-0024B-R2, 33-0024B-R3, 33-0024B-R4

Warranty: 1 year Limited Manufacturer’s Warranty

  IMPORTANT: Damage due to incorrect installation is not covered under warranty.

Customer Reviews

Based on 2 reviews
50%
(1)
50%
(1)
0%
(0)
0%
(0)
0%
(0)
J
Jim S.G.
What I needed

Replacement board. My old one got hit by an over voltage spike. Mostly plug-and-play, but there were some different pin outs, but fortunately they were all explained so it was a non-issue.

D
Dan
Works but be prepared

Works good and actually better than the R2 version, this version seems more efficient and runs the pumps differently, water seems cleaned so maybe the ozone is working now. Be prepared to troubleshoot this yourself and the cross reference is not very accurate. I had two wires going to Pin 33 had to break them up. Also make sure you set the jumpers.